2013 Subaru Impreza

//2013 Subaru Impreza

2013 Subaru Impreza

Subaru Impreza

Mileage
135,210
Service Date
9/8/2022
Services Performed
  • Confirmed code in ECM and ABS (see printout) double checked cam sensor connections. Cleared codes. Traction lamp went out after engine code clear. went into ABS unit as well and cleared the single code. Airbag light on also. Test Drove with live data of cams and both sides read/perform equally. no surging, or lumping idle. Read codes on return and found none pending or active. Put car in rack and did visual inspect of underside and found no leaks and no issues of concern. Test drove 2nd time for longer to confirm that the performance did not change. Both low beam bulbs inop. Recommend oil change with high quality oil as well as OEM filter. It is common for this system to have issues due to incorrect oil, dirty oil or poor filtration from low quality filters. If problems persists, further diag will be required but faults/symptoms must return to be able to check into it further. Customer requested low beam bulbs be replaced. Replaced both with new.
  • Added to engine flush before change. Ran to operating temp @ different rpm ranges, drained while warm. Replace engine oil and filter. Test drove for another 10+ mi, no CEL or running issues returned. Recommend driving vehicle normally and return for further diagnosis if faults or symptoms return. Recommend oil changes at 5k intervals – next change due at 140k
 
Nick T. gave our service a 5 star review on 9/9/2022
2022-09-10T22:00:47+00:00