mitchell1

/CRM Mitchell1

About CRM Mitchell1

This author has not yet filled in any details.
So far CRM Mitchell1 has created 130 blog entries.

2015 Volkswagen Jetta

2022-11-05T22:01:14+00:00

Volkswagen Jetta

Mileage
63,518
Service Date
11/4/2022
Services Performed
  • 3 Faults stored in engine module o/a: 009218 – EVAP Leak Detection Pump Control Circuit P2402 – 000 – Short to Plus 009226 – EVAP System Leak Detection Pump Heater Control Circuit P240A – 000 – Open Circuit 001095 – Control Circuit for EVAP Vent Control P0447 – 000 – Open Circuit Bulb out warning on in dash – customer states this is intermittent. Coolant level low o/a – almost to low mark. Performed cooling system pressure test and topped up coolant as needed. Oil filter leaking o/a – removed and found filter had been previously damaged, looks like it was trying to be removed with pliers. Filter was VERY over tightened. Filter was damaged further during removal. Found oil cooler nut was loose, tightened and installed new filter – no more oil leak. Cleaned under tray from oil drip as well as area around leak. Noise from rear brakes audible o/a – removed DS rear wheel and found a bunch of debris and sand behind rotor. Cleaned and noises stopped. Removed EVAP purge valve and tested – does not hold vac on either side when valve is closed. Performed actuation test via scan tool and valve opens/closes on command. Recommend new valve due to leak. Burned out RF DRL lamp. Only comes on with ignition on, not on from the light switch. Have to pull bumper skin and H/L assembly to get to the bulb. Cigarette lighter not working. Found blown fuse in interior fuse panel. Had a blown 30 amp fuse in it, calls for a 20amp. Also has interior lamps on same circuit. Replaced with 20 amp fuse, lighter and lights came back on. Fixed. Do not put bigger fuse as replacement.
 
Megan W. gave our service a 5 star review on 11/4/2022
2015 Volkswagen Jetta 2022-11-05T22:01:14+00:00

2018 Mazda CX-9

2022-10-27T22:01:45+00:00

Mazda CX-9

Mileage
92,606
Service Date
10/26/2022
Services Performed
  • Customer states car was running fine but was having issues starting. Took to willettes and they replaced spark plugs and the battery and then car ran very poorly and was brought here. Car will start but audibly is not running on all cylinders. Engine power is low – at full throttle it barely gets up to 30mph. No CEL o/a, pulled in shop to inspect and smelled very strong sulfur smell from exhaust. Performed complete obd2 scan. No faults in ECU or TCM. Ran engine for a few minutes monitoring engine data, engine makes very little power and has strong sulfur smell after any running time. No misfires during rough running registered. All fuel data looks normal. Noticed Cat temp reached 540deg after about 5 min of idle time and smell from left exhaust got significantly worse. Removed spark plugs and checked gap, gap was a tad large on 2 plugs – re-gapped and re-installed. Engine now runs normally and starts easily. No CEL present after test drive. Since willettes installed plugs they took care of the cost for this repair.
 
Julie R. gave our service a 5 star review on 10/26/2022
2018 Mazda CX-9 2022-10-27T22:01:45+00:00

2016 Toyota Tacoma

2022-10-21T22:01:40+00:00

Toyota Tacoma

Mileage
59,915
Service Date
10/20/2022
Services Performed
  • Oil filter cap was VERY tight but came off without damage. Old filter was very poor quality and previous worker put grease around o-ring. Cleaned cap and replace oring and filter with new. Filled oil with 0w-20 full synthetic. Checked tire pressures – all where around 25psi, set all 4 to 35psi and reset tpms. Reset service reminder. Recommend 5k intervals for oil changes. Topped up windsheild washer fluid.
 
Michele W. gave our service a 5 star review on 10/20/2022
2016 Toyota Tacoma 2022-10-21T22:01:40+00:00

2018 Subaru Impreza

2022-10-19T22:01:21+00:00

Subaru Impreza

Mileage
15,780
Service Date
10/18/2022
Services Performed
  • Oil and filter change. Reset oil, filter, and tire inspection notices. (set @ 32 psi) Fluids are good, no visible leaks. sap and bugs on front bumper and hood on arrival. and 1 small white scuff mark on driver's fender
 
Wayne T. gave our service a 5 star review on 10/18/2022
2018 Subaru Impreza 2022-10-19T22:01:21+00:00

2011 Subaru Outback

2022-09-29T22:01:19+00:00

Subaru Outback

Mileage
154,224
Service Date
9/28/2022
Services Performed
  • Pressure tested cooling system. Radiator was full on arrival. Held 17psi for long time with No leaks found underneath, or evidence of any head weep. Temp gauge can climb past normal with a/c on during sustained climbs is possible, even without visible leak. Block test is next test avail.
  • Customer noted on drop off that 3 studs have broken on 3 different wheels. He would like to replace ALL studs on each wheel with new studs. RR done (5) LR getting new wheel bearing due to noise Need 10 studs and some new lug nuts to complete the fronts.
  • Replaced rear section and muffler. Flange on rear cat section is VERY rusted but was able to secure using replacement used hardware. Hangers are all in good shape. Installed new gasket at front of rear section and at muffler junction.
  • LR bearing done. Very rusty/hard fight. Needs new mounting bolts @ next visit. Test drove and its quiet. Replaced all 4 bolts with new oem hardware 9/28 – BP
 
Sean W. gave our service a 5 star review on 9/28/2022
2011 Subaru Outback 2022-09-29T22:01:19+00:00

2011 Subaru Outback

2022-09-22T22:02:40+00:00

Subaru Outback

Mileage
178,538
Service Date
9/21/2022
Services Performed
  • Confirmed RR wheel bearing is broken, not just worn out. (mega play)I would not drive it much further, especially @ highway speed. Some rust to work around nut not alot. TPMS is flashing on arrival. Front bumper skin is popped out of clip on LF corner No visible leaks underneath. Some front suspension light rattle heard when driving. End links are easy to move and struts feel a little splashy. they look to be the original struts.
  • Remove and replace RR bearing assy. Needed 1 new bolt because 1 got damaged on removal due to rust factor. Installed customers RR rotor and pads from his leftover brake kit in trunk.
 
Joe R. gave our service a 5 star review on 9/21/2022
2011 Subaru Outback 2022-09-22T22:02:40+00:00

2013 BMW X5

2022-09-16T22:03:58+00:00

BMW X5

Mileage
102,802
Service Date
9/15/2022
Services Performed
  • Performed obd2 scan – 8 faults stored in various modules – see full report. Engine module had 00459C Cylinder 1 smooth running controller – absent. Cleared faults and none returned. Tires are in good condition look almost new, brakes have been recently replaced (fr and R). Checked/set tire pressures to 35f 38r, reset tpms. Coolant level was below "low" mark – performed coolant pressure test @15psi. Over about 20min pressure dropped to 13psi – no visible external leaks at this time. Engine oil was just below "low" mark – topped up with 1L but oil level did not change. Performed test drive and brakes feel good, steering is tight, no vibrations felt. Suspect slight coolant leak but not visible at this time, keep eye on coolant level and check frequently to determine how much coolant it's going through. Rear lower valance is damaged, scuff on PS rear wheel well in front of tire also. "close rear hatch" comes on randomly – checked and it is closed.
 
Kurt D. gave our service a 5 star review on 9/15/2022
2013 BMW X5 2022-09-16T22:03:58+00:00

2020 Mercedes-Benz GLE350

2022-09-12T21:59:03+00:00

Mercedes-Benz GLE350

Mileage
62,214
Service Date
9/10/2022
Services Performed
  • Removed rear wheel and checked inner pads. Inner pads are down to only a couple mm and pad sensor has been activated. Recommend rear pads/rotors be replaced soon.
  • Replaced both pads and rotors and pad sensor on PS.
 
Laura J. gave our service a 5 star review on 9/11/2022
2020 Mercedes-Benz GLE350 2022-09-12T21:59:03+00:00

2013 Subaru Impreza

2022-09-10T22:00:47+00:00

Subaru Impreza

Mileage
135,210
Service Date
9/8/2022
Services Performed
  • Confirmed code in ECM and ABS (see printout) double checked cam sensor connections. Cleared codes. Traction lamp went out after engine code clear. went into ABS unit as well and cleared the single code. Airbag light on also. Test Drove with live data of cams and both sides read/perform equally. no surging, or lumping idle. Read codes on return and found none pending or active. Put car in rack and did visual inspect of underside and found no leaks and no issues of concern. Test drove 2nd time for longer to confirm that the performance did not change. Both low beam bulbs inop. Recommend oil change with high quality oil as well as OEM filter. It is common for this system to have issues due to incorrect oil, dirty oil or poor filtration from low quality filters. If problems persists, further diag will be required but faults/symptoms must return to be able to check into it further. Customer requested low beam bulbs be replaced. Replaced both with new.
  • Added to engine flush before change. Ran to operating temp @ different rpm ranges, drained while warm. Replace engine oil and filter. Test drove for another 10+ mi, no CEL or running issues returned. Recommend driving vehicle normally and return for further diagnosis if faults or symptoms return. Recommend oil changes at 5k intervals – next change due at 140k
 
Nick T. gave our service a 5 star review on 9/9/2022
2013 Subaru Impreza 2022-09-10T22:00:47+00:00

2012 Nissan Pathfinder

2022-09-09T21:59:11+00:00

Nissan Pathfinder

Mileage
127,393
Service Date
9/6/2022
Services Performed
  • Gas light is on – low light warning on dash display. Battery was low and vehicle will not crank over. Moved into shop and put on battery charged and attempted to scan obd2. Cannot communicate via obd2 – need to get port working to be able to see engine data or faults. Even with full charge engine will not crank over. Suspect electrical issues – need to check fuses and relays for fuel pump/sensor circuit etc. Verified all related fuses are OK – no blown fuses found. Confirmed power at battery terminal and fuseble links – OK. Key on radiator fan on full is a fail safe for when there is no communication with the engine ECU. Also means no CANBUS communication with ECU. Since no comm at OBD2 port suspect issue with ECU based on info on tech info. If no communication with ECU and can lines are not broken, ECU will need to be replaced. Found tech info that showed a test for ECU failure. Tested ohm between pin 6 and 14 (can hi and lo) – 75.5 ohm. Continuity checked can wires from obd2 plug to engine ecu – passed with less than 1ohm of resistance. Suspect ECU has failed and will need to be replaced in order to diagnose further.
  • Installed new ECU and attempted to connect and program. Cannot communicate with ECU. Was able to connect and read other modules, BCM and TCM both have missing info from ECU as well as U1000 fault stored – CAN comm fault.
  • Using factory nissan programing software attempted to program blank ECU. Nissan software continually shuts off trying to detect ecu and find ecu part number to begin flashing. Contacted nissan customer service 7/11 and got a response requesting more information 7/12. Emailed all info that was requested including screenshots 7/12. Awaiting response to be able to further troubleshoot and program ECU. After waiting for 4 weeks with no support, tech support finally responded with irrelevant information for issues with the flash software. After making multiple attempts to program and continuing software issues and no support, the customer decided to have the car towed to a dealership to complete the programming and for further diagnosis if needed. Old ECU is in passenger seat, new ECU is completely installed.
 
Tim S. gave our service a 5 star review on 9/8/2022
2012 Nissan Pathfinder 2022-09-09T21:59:11+00:00